О программе ArtMoney
Return to Introduction

ArtMoney

Профессиональная редакция PRO v7.10
( 17 октября 2004 года )

Copyright (C) 1996-2004, ArtMoney Team.

Об ошибках и пожеланиях пишите
artmoney@mail.ru

Посетите сайт ArtMoney и скачайте последнюю версию
www.artmoney.ru


Лицензионное соглашение

Лицензионное соглашение для
Профессиональной редакция PRO v7.10
Return to Introduction

1. Это лицензионное соглашение является юридическим соглашением между Вами и автором этой программы
2. Устанавливая или используя эту программу Вы полностью соглашаетесь с этим соглашением. Если Вы не согласны с условиями этого Соглашения, Вы не можете устанавливать или использовать эту программу.
3. Данная редакция программы v7 PRO платная, для жителей России и стран СНГ - $10, для остальных стран $20 на одного пользователя. Вы платите только один раз, все последующие обновления бесплатны. Перед установкой и использованием программы вы должны оплатить указанную сумму.
4. Автор не несёт никакой ответственности за порчу и потерю информации.
5. Вы не имеете права использовать эту программу для нарушения какого-либо международного закона или закона вашей страны .
6. Вы не имеете права использовать эту программу для нарушения авторских и имущественных прав каких-либо лиц.
7. Вы не имеете права использовать эту программу в играх, в которых вы можете выиграть (заработать) реальные деньги или вещи.
8. Вы можете установить и использовать неограниченное количество копий этой редакции программы на ваших компьютерах.
9. Вы не имеете права выпускать для распространения или продажи другим лицам) эту редакцию программы, ключи или пароли на CD или других носителях.
10. Вы не имеете права выкладывать эту редакцию программы, ключи или пароли на каком либо интернет сайте.
11. Вы не имеете права передавать эту редакцию программы, ключи или пароли другим лицам.
12. Вы не можете дизассемблировать или переделывать любую часть этой программы.
13. Запрещается использовать эту программу в коммерческих целях без согласия автора. "В коммерческих целях" означает для получения денежной или прочей материальной выгоды. Вы не можете арендовать,передавать в аренду или продавать эту программу.
14. Зарегистрированные пользователи PRO редакции получают техническую поддержку по электронной почте.
15. Автор будет исправлять ошибки в программе, так быстро, как только возможно. Автор будет уведомлять зарегистрированных пользователей о выходе новых версий по электронной почте.
16. Автор имеет право отменить лицензию в случае нарушения пользователем любого пункта данного соглашения.


Для чего эта программа

Программа ArtMoney создавалась как универсальный взломщик к любым играм.

Она умеет сканировать память или файлы игры для поиска каких-то определенных значений (деньги, ресурсы и т.д.).
Таких значений может быть много и надо выбрать нужные, поэтому поиск разделяется на два этапа: поиск значений и отсев ненужных значений.

В итоге получаем адреса, в которых находятся числа, и их можно изменить на нужные. Специальные методы позволяют обмануть даже игры, в которых нет числовых видимых значений (например: графическая полоска жизни) или игры, которые кодируют свои данные.
ArtMoney не работает в режиме сетевой игры ( т.е. человек против человека ), поскольку деньги могут дублироваться на нескольких компьютерах, и изменение денег на одном (на вашем ) не приводит к успеху, хотя и тут есть исключения.


Мы ждем Ваших писем

Пишите artmoney@mail.ru

· Мы ждем ваших писем с предложениями и вашими таблицами!
· В связи с большим количеством получаемых писем, ответ на ваше письмо может задержаться на неделю и даже более, но мы обязательно ответим на все ваши вопросы.
· Обязательно в поле тема пишите слово ArtMoney и номер версии, иначе ваше сообщение считается спамом и удаляется автоматически.
· Обязательно в поле тема или теле письма указывайте свой регистрационный номер.
· Мы не даем бесплатных консультации по программированию.
· Мы не высылаем исходники бесплатно, вы можете их только купить.
· Надеюсь вам понравилась эта программа. Если Вы хотите перевести ArtMoney на другой язык, то пишите нам. Пока и удачи во всём.


Требования к системе

· Полностью IBM PC AT совместимый компьютер минимум 80486 с 4Mb ОЗУ или выше
· Операционная система Microsoft Windows 95/98/ME/NT4/2000/XP/2003


Особая благодарность

Особая благодарность за помощь в дизайне
· Сергей Миронов

Особая благодарность за иконку
· Смородин Евгений

Особая благодарность за логотип
· Алексей Шевченко

Особая благодарность за установочный модуль
· Razali Rambli

Особая благодарность за грамматическую проверку английского
· Jacob Poon
· Алексей Кушниров

Особая благодарность за помощь
· Rex Armour

Особая благодарность за пакет ThemeEngine (поддержка скинов)
· Евгений Крюков (www.ksdev.com)

Особая благодарность за советы и ценные замечания
· Сергей Миронов
· Виталий Кондратьев
· Андрей Захаров
· Вениамин Смирный
· Роман Симонов
· Дмитрий Головин
· Алексей Зубов
· Эльдар Хаспулатов
· Леонид Мастеров
· Ярослав Петровский
· Виктор Иванов
· Сергей Стекольников
· Solkien DarkEye
· Дмитрий Щетников
· Евгений Сазонов
· Павел Триодин
· Whatsmore
· Денис Тулупов
· Василий Андрюсенко
· Сергей Голивец

Особая благодарность за переводы
· Дмитрий Вегнер ( немецкий плагин и руководство пользователя )
· Владимир Афанасьев ( итальянский плагин )
· Aleksandrs Basalajs ( латышский плаги )
· Moises Glez ( испанский плагин )
· Solkien DarkEye ( французский плагин )
· Ярослав Петровский ( украинский плагин )
· Kraguljac Marko ( сербский плагин )
· Mario Benvenuti ( португальский плагин )
· Денис Соколов ( литовский плагин )
· Groteb ( голландский плагин )
· Tofi-Brno ( чешский плагин )
· Whatsmore ( китайский плагин )
· Nurglath ( греческий плагин )
· Михаил Балабанов ( болгарский плагин )
· Allen Lim ( китайский BIG5 плагин. Используется на Тайване и в Хонг Конге )
· Алексей Мицкевич ( беларуский плагин )
· Denis Fomichevskij (беларуское руководство пользователя)
· Muzaffar Babenko (украинское руководство пользователя)
· Adrian G. Kousz ( немецкий плагин )
· Aytac KARAHANCI (турецкий плагин)
· B_A_T ( польский плагин)
· Catoliquot Cedric ( французский плагин )
· Tovcaci Yuri ( румынский плагин )
· Geza Gabriel ( венгерский плагин и помощь)
· Андрей Слезенко ( украинский плагин )
· Marc Renщ Delhalle (немецкая помощь)
· Tino Khong (Вьетнамский плагин)
· Bui Tung (Вьетнамская помощь)
· Adrian Mihalko (Словацкий плагин)

Особая благодарность за таблицы
· Дмитриев Денис
· Виктор Рябинин
· Евгений Сазонов
· Thomas Ally
· Егор Сербаев
· Владимир Графинин
· Константин Докучаев
· Якорев Даниил
· Василий Андрюсенко
· Илья Воронов
· Алексей Соловьев

В раздел "благодарность за таблицы" включены люди приславшие больше всех таблиц. Все люди перечисленные в разделе благодарности имеют право получить редакцию PRO бесплатно!
Для этого они должны послать запрос на адрес artmoneypro@mail.ru. Указать в письме свое имя, фамилию, страну, город проживания. И короткую фразу (или просто слово) как пароль для случая если вы смените email и потеряете ключ или пароль. Все кто пришлет 10 и более таблиц, которых нет на сайте, также могут получить редакцию PRO бесплатно!


Руководство к действию. Как ломать игру.

1. Итак, перед вами новая игра! И очень хочется чего ни будь с ней сделать. Данная программа умеет это делать двумя способами, два разных объекта для поиска - процесс или фаил, переключаются в настройках, пункт "Объект".

2. Первый способ - поиск в памяти процесса игры. Запустите ArtMoney и потом игру. Выберите, какой параметр, вы хотите сломать и запомните его. Переключитесь из игры на ArtMoney, используя Alt-Tab. Если не помогает, то Ctrl-F12. Теперь выберите процесс с игрой. Если, например, хотим денег, жмем на кнопку "Искать" и выберем метод искать "Точное значение". Поскольку игра не знакомая, то ставим тип - все(стандартные). Как действовать дальше, читаем тут "Поиск точного значения"

3. Ага, получилось, поздравляю! Нет - продолжаем ломать. Некоторые, не очень умные игры используют числа с десятичной точкой, как, например Age Of Empires. Причем, после точки имеют некоторые цифры, но при этом учитывают только целую часть. Например, денег 2456, а хранится как 2456.0011 или 2455.9999. Жмем на кнопку "Искать" и выберем метод искать "Диапазон значение". Ставим тип - С точкой(стандартные). Вводим "Значение 1" - 2455.5 , "Значение 2" - 2456.5. Как действовать дальше, читаем тут "Поиск диапазона значений"

4. Если, например, хотим сломать жизнь, причем эта жизнь представлена в виде полоски или шарика, то есть цифр на экране не видно жмем на кнопку "Искать" и выберем метод искать "Неизвестное значение". Поскольку игра не знакомая, то ставим тип - все(стандартные). Как действовать дальше, читаем тут "Поиск неизвестного значения"

5. Неужели, ничего не получается?! Попробуйте выбрать другой параметр в игре. Например, в игре Allods значение денег зашифровано, а количество предметов легко меняется, поставьте себе один миллион мечей и продайте их, получите кучу денег. В игре Warcraft 3 значение денег зашифровано, однако легко ломается количество золота в шахте - а ведь это бесконечные деньги.

6. До сих пор не получилось?! Это весьма странно, теперь остаётся только последнее и универсальное средство - "Поиск кодированного значения". Занятие это весьма геморройное, может занять не один час. Иногда всё срывается. Но результата достичь всегда можно. Как действовать дальше, читаем тут "Поиск кодированного значения" Программа имеет много настроек, и нужно только определить, какие для какой игры установить. В любом случае, вы можете поискать игру в разделе таблиц на сайте программы и написать автору этой таблицы.

7. Второй способ - поиск в файлах игры. Почти каждая игра сохраняет на диск файлы-записи, в большинстве случаев они называются также как запись или сохранение в игре. К сожалению или к счастью, почти все современные игры использует архивацию своих данных. То есть, искать в этих файлах бесполезно. Первым признаком такого кодирования, является разный размер файлов-записей. Итак, запустите игру и сохраните её несколько раз с разным количеством денег. Потом запустите ArtMoney, и далее читаем тут "Поиск в файлах"


Поиск точного значения.

Поиск точного значения:
На примере игры "Heroes Of Might And Magic 4".
Return to Introduction

1. Запустите ArtMoney. Запустите игру. Нажмите Alt-Tab и перейдите на ArtMoney. Если не помогает, то Ctrl-F12. Теперь выберите процесс с игрой.

2. Затем нажмите кнопку "Искать" и наберите число для поиска. Рекомендуемый тип "Целые (стандартные)", однако вы можете выбрать другой тип или набор типов в списке типов. Пусть, например, у вас 15000 монет.

3. При выборе в списке типов "Ваш набор" появится окошко, в котором вы можете сами выбрать интересующие вас типы переменных. Для денег обычно выбираем целое 4 байта.

4. Итак, при начале поиска появляется окошко со шкалой. Когда шкала закончится - поиск завершён. Нажмите кнопку "OK".

5. Скорее всего, после поиска будет очень много чисел, но не все они истинные, обычно только одно. Вам необходимо отсеять найденные числа. Переходим на игру по Alt-Tab. Измените значение в игре. Например, вы покупаете что-нибудь, и денег становится 14460. Возращаемся в ArtMoney. Нажмите кнопку "Отсеять". И наберите новое значение. Нажмите OK.

6. Продолжайте отсеивать, пока количество найденных чисел не будет уменьшаться. После этого переместите числа из левой в правую таблицу, нажав кнопку "Добавить" (Стрелочка).

7. В правой таблице вы можете делать с числами всё, что захотите: изменять, удалять, копировать, заморозить его значение ( не дать игре его изменить ). Для изменения значения двойной щелчок мыши на числе. Для заморозки щелчок мыши в первом столбце соответствующего значения. Вы можете сохранить эту таблицу, чтобы потом снова не искать всё заново, в просто загрузить. Используйте для этого клавиши "Сохранить", "Загрузить" в самом низу главного окна.


Поиск диапазона значений
На примере игры "Age Of Empires 2".
Return to Introduction

Если вас интересует некоторый диапазон значений, то попробуйте это. Также можно использовать, если значение неизвестно. Например, шкала жизни в начале полная (100%). Ищите точное значение 100. А потом вас немного повредили, и у вас стало, примерно 80%. Отсеивайте в диапазоне от 79 до 81. Еще можно использовать, если число с точкой, а на экране отображается только целая часть. Например, отображается 80, тогда ищите в диапазоне от 79.5 до 80.5 , то есть с погрешностью 0.5 Сломать игру "Age Of Empires 2" без этого метода вообще не возможно. Тип переменной - с точкой 4 байта. Нужно искать в диапазоне с погрешностью до одного. Например, золота 2456, тогда ищите диапазон от 2455 до 2457. При отсеивании действуем аналогично.


Поиск неизвестного значения
На примере игры "Heroes Of Might And Magic 3".
Return to Introduction

Что делать, если в игре полоска без цифр? Как найти это значение? В этом случае вы должны использовать поиск "Неизвестное значение". Рекомендую выбрать конкретный тип, например, для жизни "целое 1 байт" или "целое 2 байта", так как весь процесс может занять продолжительное время. Итак, самый важный шаг - первое отсеивание, необходимо изменить жизнь, но так чтобы все остальное как можно меньше изменилось, в том числе изображение на экране.

Например, я взял игру HMM3 и нашел деньги методом поиска неизвестного значения ( результат смотрите в таблице ). Процессор - Pentium 233, память - 32Mb. Тип числа - целое 4 байта. Всего у меня на нахождение денег ушло 22 минуты, так как игра довольно большая ( размер данных процесса 27Mb ).
Первое отсеивание было довольно удачное ( найдено всего 173 тысячи адресов ), а в случае если изображение на экране изменяется, то второе отсеивание увеличивается в два раза, и общее время практически до 35 минут. Самым продолжительный по времени всегда третий шаг - второе отсеивание. Уже на 16 шаге стало понятно, где деньги, однако лучше всего продолжать пока найденные адреса не перестают уменьшаться, а после этого находим деньги перебором, то есть просто заносим по адресу какое-нибудь число и смотрим, не изменились ли деньги в игре.
Данный метод хорошо сочетается с поиском диапазона значений, особенно для полосок энергии. Для уменьшения общего времени взлома на 5-10 шаге отсейте заведомо ложные значения.
Оставьте, например, только от 0 до 200, правда это не всегда справедливо, поскольку одно деление жизни может быть равно какому-то числу, например, для игры Half-Life одно деление жизни хранится как 171, то есть если у вас 100%, то в памяти оно хранится как 17100.

Шаг | Деньги | Изменение | Время | Найдено адресов
1 | 24547 | -:- | 30 сек | 27Mb
2 | 24597 | увеличилось | 2 мин | 173451
3 | 847 | уменьшилось | 3,5 мин | 88053
4 | 9847 | увеличилось | 2,2 мин | 59142
5 | 9947 | увеличилось | 1 мин | 19800
6 | 14447 | увеличилось | 20 сек | 5500
7 | 0 | уменьшилось | 13 сек | 3378
8 | 100 | увеличилось | 10 сек | 1964
9 | 850 | увеличилось | 3 сек | 720
10 | 0 | уменьшилось | 2 сек | 535
11 | 8000 | увеличилось | 2 сек | 329
12 | 9300 | увеличилось | 1 сек | 122
13 | 0 | уменьшилось | 1 сек | 91
14 | 1150 | увеличилось | 1 сек | 59
15 | 9150 | увеличилось | 0,5 сек | 21
16 | 9950 | увеличилось | 0,4 сек | 9
17 | 6200 | уменьшилось | 0,3 сек | 8
18 | 0 | уменьшилось | 0,2 сек | 5
19 | 8050 | увеличилось | 0,1 сек | 4
20 | 3790 | уменьшилось | 0,1 сек | 4


Поиск кодированного значения
На примере игры "Imperium Galactica 2".
Return to Introduction

На экране деньги изменяются, а на самом деле нет. Что делать?
Это как раз и есть случай кодирования данных. Этот метод используется, только если остальные методы для всех типов ничего не дали. Итак, нажимаете "Поиск" и выбираете "Искать - Кодированное значение" и жмете OK. После этого изменяете значение в игре и делаете отсеивание. Теперь при следующем отсеивании вы можете выбрать, изменить величину или не изменить. Продолжайте отсеивать, пока количество найденных чисел не будет уменьшаться. После этого попробуйте заморозить все найденные числа. Ваше кодированное значение будет заморожено. Это всё, что в этом случае можно сделать. Итак, ломаем деньги в "Imperium Galactica 2". Несколько раз меняем значение, потом не меняем. После 20-25 шагов остается 3 значения. Переносим их в таблицу и заморозим. Тратим денег сколько угодно, они у нас теперь не кончаются:-)


Поиск последовательности значений
На примере игры "Heroes Of Might And Magic 2".
Return to Introduction

Бывает в игре кроме денег надо еще копить различные ресурсы ( пшено, кристаллы, бревна, ракеты, численность армии и т.д.), так вот эти ресурсы если на экране идут подряд, то и в памяти, обычно, идут в той же последовательности, именно эту последовательность и можно найти. Особенно мне помогло в таких играх, как HMM2 ( численность армии ) и Settler 2 (ресурсы). В некоторых играх дата записывается как последовательность целых чисел - месяц, число, год ( например HMM3 ). Итак играем в "Heroes Of Might And Magic 2" и надо же идёт противник с большой армией и убивает ваш город. В вашем городе 1 дракон, 9 мышей, 17 грифонов. Делаем поиск последовательности трёх чисел "целое 2 байта". И вот, получаем 3 значения в таблице. Никакого отсеивания не надо!


Поиск в блоке памяти
На примере игры "Горький-17".
Return to Introduction

Часто ресурсы в игре (деньги, камни, лес, жизнь броня, и т.д.) находятся в одном блоке памяти. Сканировать только один блок игры намного быстрее, чем всю игру, особенно для неизвестного значения. Просто выберите команду контекстного меню "Искать в этом блоке памяти" и автоматически все параметры поиска будут установлены на блок памяти, соответствующий текущему выделенному адресу. Если в полученном блоке вы не нашли чего хотели, то попробуйте расширить его, указав в настройках свои диапазон адресов. Внимание! Обратно установки поиска нужно исправить самому, убрав галочку в опциях "Искать в диапазоне адресов".

Итак, играем "Горький-17" у персонажа осталось 5 очков жизни, он стоит около врага и умирает при любом ударе. Кажется, ничто уже не поможет. Итак, ищем опыт персонажа 10150 очков. Находим одно значение. Делаем команду "Искать в этом блоке памяти" и ищем число 5 (целое 2 байта). Находим 106 значений, осталось только определить которое. Выделяем всё и делаем команду "Установить значение" значение = 1, Шаг = 1. Переключаемся в игру и видим, что жизни стало 89, значит нужное нам значение под номером 89. Остальные удаляем. Ставим жизни 200 очков, сохраняем игру, и перезапускаем её. Перезапускать надо, чтобы глюков не было, поскольку мы исправили какие то случайные ячейки.


Использование указателей и Авто изменение адресов
На примере игры "Warcraft 3".
Return to Introduction

Если случается так, что ранее найденные и сохраненные адреса становятся недействительными, это значит, что игра использует динамическое распределение памяти . Недействительные адреса - это значит, что там не то, что в игре или нет никакого значения вообще (пишется <НЕТ>). Итак, рассмотрим природу этого явления "динамическое распределение памяти" по английски "Dynamic Memory Allocation" сокращенно DMA. Когда игре необходима дополнительная память она использует функцию Windows для получения памяти. Windows раздает участки памяти случайно, то есть по DMA. Из этого следует, что перезапуск игры приводит к полной переделки всей карты памяти. Блоки памяти меняются местами, адреса меняются.

Использование "Авто изменение адресов"

Итак, после перезапуска игры все адреса поменялись. В этих случаях вам не нужно находить заново все изменившиеся адреса. Сначала найдите новый адрес одного из изменившихся адресов. Затем выделите старый адрес в правой таблице и новый адрес в левой таблице и используйте команду меню "Авто изменение адресов". Практически, программа находит разницу между старым и новым адресом. И прибавляет эту разницу ко всем адресам в таблице.

На пример, качаем с сайта ArtMoney таблицу "Warcraft 3 (hero)" от JS. Запустите ArtMoney и потом игру "Warcraft 3". Переключитесь из игры на ArtMoney используя Alt-Tab. Загружаем таблицу в ArtMoney. Мы видим это

Мда совсем не то. Ищем опыт (Experience), у меня он равен 600. Убиваем в игре кого нибудь опыт стал 650. Отсеиваем. Получаем один адрес 021D071C. Делаем как показано на рисунке команду "Авто изменение адресов на все". В случае разбивке по группам делаем "на группу"

Получаем в результате это

Вуаля, все работает!

Использование указателей

Указатели используется только в играх Win32 имеющих исполняемый фаил. Никакие DOS игры, эмуляторы, интернет браузеры и игры Macromedia Flash указателей не имеют! И искать их бесполезно!

Адреса меняются после перезапуска игры. Но игра должна знать, где её параметры поэтому существует ячейка в которой записан адрес этого параметра. Эта ячейка называется указателем на адрес, фактически она его содержит

Адрес указателя при перезагрузке игры не меняется. То есть, если адреса в таблице привязать к указателю, то получим таблицу значения в которой всегда актуальны. Итак, выделяем ячейку с опытом и делаем команду "Искать указатель на этот адрес". Находим этот указатель и привязываем командой "Установить указатель на все" или "на группу".

Упс, но мы ничего не находим! Это значит что указатель не на адрес с опытом, а на структуру, начало которой мы не знаем. Итак, опять выделяем ячейку с опытом и делаем команду "Искать указатель на начало блока памяти".

Тем самым мы найдем все указатели на диапазон адресов между началом блока и ячейкой с опытом.
Таких указателей нашлось 521 штук. Выделяем ячейку с опытом и делаем команду "Сохранить Адрес/Указатель". Очищаем таблицу и переносим все указатели в таблицу. Делаем команду "Установить все указатели на сохраненный адрес". Теперь все указатели указывают на этот адрес 021D071C

Перезапускаем игру. Делаем команду "Установить фильтр" на значение 650. Такой адрес один. Если адрес не один, то перезапускаем игру и опять делаем фильтр. Итак, несколько раз. Если все равно получается несколько адресов, то выбираем любой. Выделяем этот адрес и делаем команду "Сохранить Адрес/Указатель".

Загружаем изначальную таблицу. Выделяем ячейку с опытом и нажимаем "Установить сохраненный указатель на все". Вот и всё ребята! Мы имеем таблицу, адреса которой не меняются при перезагрузке игры.

Указатель 6F71C7B8 указывает на адрес 01420088
Адрес 01420088 есть адрес начала структуры описывающей нашего героя.
Адрес 01420088 плюс смещение 1684 равный 0142071C есть адрес опыта.
Тем самым мы привязались к адресу началу структуры, и имеем дело с относительными адресами.
Адрес опыта 1684 относительно начала структуры получаемого из указателя 6F71C7B8.
Полученная таблица выглядит следующим образом:

Указатель 6F71C7B8 + 1684 / Experience
Указатель 6F71C7B8 + 1688 / Points
Указатель 6F71C7B8 + 1692 / Power
Указатель 6F71C7B8 + 1712 / Dexterity
Указатель 6F71C7B8 + 1712 / Health
Указатель 6F71C7B8 + 1744 / Manna

Возможные действия с указателями:

1. Сохранить адрес/указатель - сохранить адрес/указатель/смещение для последующей работы
2. Установить указатель на все (на группу) - выделяем один указатель в найденных и один адрес в таблице, сопоставляем их, то есть предполагается, что искали указатель на этот адрес, остальные адреса/указатели в таблице переводятся в указатели со смещение относительно исходного адреса.
3. Установить сохраненный указатель на все (на группу) - тоже самое, что выше, но указатель берется из сохраненного командой "Сохранить адрес/указатель ". Плюс дополнительно добавляется ко всем смещениям - сохраненное смещение.
4. Установить все указатели на этот адрес - всем указателям в таблице присваевается смещение, чтобы они указывали на этот адрес ( адрес должен быть выделен).
5. Установить все указатели на сохраненный адрес - тоже самое, что выше, но адрес берется из сохраненного командой "Сохранить адрес/указатель ".
6. Преобразовать указатели в адреса - обратная команда к "Установить указатель". Все выбранные указатели превращаются в адреса.

P.S.

Кроме того, указатели можно искать и как любые другие значения. Для этого вам нужно запустить два ArtMoney, из разных каталогов (из одного работать не будет). Можно использовать один ArtMoney, но использовать Сохранение/Загрузку отсеиваний.

1. Запустите игру. Найдите адрес жизни A1. Сделайте поиск неизвестного значения.
2. Перезапустите игру. Найдите адрес жизни A2. Ищите "Увеличилось на (A2-A1)"
3. Перезапустите игру. Найдите адрес жизни A3. Ищите "Увеличилось на (A3-A2)"

Наконец вы получите адрес указателя.
Смещение = адрес жизни (A3) - значение указателя.


Поиск в файлах.
Почти каждая игра сохраняет на диск файлы-записи, в большинстве случаев они называются также как запись или сохранение в игре. К сожалению или к счастью, почти все современные игры использует архивацию своих данных. То есть, искать в этих файлах бесполезно. Первым признаком такого кодирования, является разный размер файлов-записей (при сохранении в одном месте игры).

Запустите игру и сохраните её несколько раз с разным количеством денег.
Потом запустите ArtMoney. Выберите первый файл-запись. Затем нажмите кнопку "Искать" и наберите число для поиска, количество денег при первом сохранении.

Скорее всего, после поиска будет очень много чисел, но не все они истинные, обычно только одно. Вам необходимо отсеять найденные числа. Выберите второй фаил-запись. Затем нажмите кнопку "Отсеять" и наберите количество денег при втором сохранении.

Продолжайте отсеивать, пока количество найденных чисел не будет уменьшаться. Выбирайте третий фаил-запись и т.д. После этого переместите числа из левой в правую таблицу, нажав кнопку "Добавить" (Стрелочка).


Отсеивание по формуле
Отсеивание по формуле. Самый мощный механизм поиска. Сохраните несколько раз дамп памяти. Вы имеете несколько состояний объекта M1,M2, и т.д.
Например, состояние полоски жизни одинаково на 1 и 3 состоянии. Теперь сделайте отсеивание по формуле "(M1<>M2)and(M2<>M3)and(M1=M3)". И вы легко нашли адрес жизни.

Формула дает возможность найти адрес переключившись на ArtMoney всего один раз. И это еще не все! Формула позволяет находить сразу неограниченное количество параметров. Например, в игре "Jagged Alliance 2" можно найти сразу патроны для 12 наемников. Для этого сохраните несколько раз дамп памяти с помощью нажатия клавиш. Запомните или запишите у кого сколько патронов. Далее переключитесь на ArtMoney и 12 раз введите формулу для каждого наемника.
Например для первого наемника (M1=12)and(M2=6)and(M3=1).

Формула представляет собой логическое выражение, которое может содержать:

· Другие выражения в скобках ()
· Аргументы (M1,M2, и т.д.) - Cостояния объекта (дамп памяти или набор адресов и значений). Дамп памяти это полный слепок объекта на какой-то момент времени.
· Набор аргументов M[2,4] - Cостояния объекта на 2 и 4 шаге. Например, M1 <> M[2,4] то же самое (M1 <> M2) and (M1 <> M4)
· Числа (100,-15,Ah,11.2) - Два числа в выражении может быть только в выражении вида 100>=M1>=300
· Текст ('Boss',"Good") - только для выражения вида M1='Boss'
· Условия ( "<",">","=" и т.д.) - например, M1=1, M2>=100, 1<=M3<=2, или для сравнения состояний объекта M1>M2, M1<>M2.
· Арифметические действия ('+','-') - только для выражения вида M2>=M1+100
· Операция AND - объединение двух наборов адресов, которые есть в 1 и в 2 выражении.
· Операция OR - объединение двух наборов адресов, которые есть в 1 или в 2 выражении.

В формуле можно использовать любое количество вложенных пар скобок. Содержимое каждой из этих пар скобок должно быть логическим выражением. На выходе каждого выражения должен быть набор адресов и значений.

Помните, что операции AND, OR возвращают только набор адресов. Они должны выполняться только в последнюю очередь. Например, 100<=(M1 and M2)<=300 - даст не верный результат, набор значений не определен. Правильный вариант (100<=M1<=300)and(100<=M2<=300).

Выражения типа, M1>M2, M2<>M1 возвращают набор адресов и набор значений одного из аргументов. Например, результат (M1<>M2)>0 совершенно одинаков с (M1>0)<>M2

Выражения типа M1=M2 возвращает правильный набор адресов и значений, поскольку значения одинаковы. Например, результат (M1=M2)>0 совершенно одинаков с (M1>0)=(M2>0)

Например, если вы ищите точное значение и имеете 3 шага со значениями 15000,14460,15100, правильная формула будет (M1=15000)and(M2=14460)and(M3=15100)

Например, если вы ищите диапазон значений и имеете 2 шага со значениями примерно 100 и 200, правильная формула будет (99.9<=M1<=100.1)and(199.9<=M2<=200.1)

Например, если вы ищите неизвестное значение (полоска жизни) и имеете 4 шага со значениями примерно 100%,80%,60%,90%, правильная формула будет (M1 > M2)and(M1 > M3)and(M1 > M4)and(M2 > M3)and(M2 < M4)and(M3 < M4)

Например, если вы ищите закодированное значение и имеете четыре различных состояния объекта, правильная формула будет
(M1 <> M2)and(M1 <> M3)and(M1 <> M4)and(M2 <> M3)and(M2 <> M4)and(M3 <> M4)
или такой специальной конструкцией
(M1 <> M[2,3,4])and(M2 <> M[3,4])and(M3 <> M4)

P.S. Рекомендуется включить режим "Разрешить отмену отсеиваний", если хотите использовать все шаги, а не только дампы памяти.


Отмена и сохранение отсеиваний

Любое ваше отсеивание (или проще говоря, шаг) можно отменить если в настройке это разрешено.
Например, вы отсеиваете на пятом шаге и ошибочно вводите число 45 вместо 54, сделайте отмену отсеивания (вы вернётесь на шаг назад) и введите правильное число 54. Отсеивание можно вернуть,то есть перейти на шаг вперед, можно сохранить под любым именем и загрузить позже. Например можно начать ломать игру, сохранить отсеивание, и продолжить через неделю.


Сохранение и загрузка процесса
Требования:
Windows 2000/XP/2003.

Ограничения:

Нельзя перезапускать процесс. Для больших игр действует только внутри одного уровня. Пока работает не на всех играх, может повесить игру. Будем работать над улучшением.

Описание:
Данная функция может использоваться для сохранения игр, где это не предусмотрено. ArtMoney сохраняет память процесса и его системное окружение. Windows всячески пытается сопротивляться, поэтому возможны сбои в процессе. Если произошел сбой, то обычно процесс просто закрывается.

Например, возьмем игру "Космические рейджеры". В ней нельзя сохраняться в гиперпространстве. Установим в настройках горячии клавиши для сохранения/загрузки ( Ctrl-F3 / Ctrl-F4 ). Далее войдя в гиперпространство жмем Ctrl-F3. На несколько секунд экран замрет, значит записались. Играем, как только нас убивают сразу жмем Ctrl-F4, экран опять замирает, и вот, мы вернулись к началу уровня. Главное не стормозить, чтобы уровень не начал выгружаться из памяти, иначе ничего не получится.

Имеются три дополнительных режима работы (устанавливаются в настройках). При включении каждого, ArtMoney начинает вмешиваться в работу процесса с момента сохранения. Чтобы увеличить вероятность успешной загрузки. Однако не все процессы переживают такое вмешательство. В случае если обычным способом не получилось загрузить, можно пытаться тогда использовать эти режимы. Перебирая их по очереди.

· Режим 1 - Отвечает за управление виртуальной памятью.
· Режим 2 - Отвечает за управление кучей памяти.
· Режим 3 - Отвечает за управление системными объектами.

Внимание! Запомните следующее:

· Больше шансов на успешную загрузку, если отключить музыку и звуки.
· Для полно экранных игр, горячие клавиши использовать, только если вы уверены, что процесс загружается правильно. То есть, до этого пробовали грузить без клавиш.
· Если вы сохраняетесь, когда игра свернута, то и грузитесь только тогда, когда она свернута.

Присылайте нам название игр в которых не получилось сохраниться, и в которых получилось тоже. Обязательно пишите версию Windows и настройки режимов.


Информация о таблице

Сохраняемые таблицы. Видимая группа.
Return to Introduction

Сохраните найденные адреса в таблицу. И в следующий раз вам не надо искать и отсеивать, просто выберете процесс с игрой и загрузите таблицу. Итак, если ваша таблица работает, то пришлите её мне, и она будет размещена на сайте программы. Желательно, чтобы все поля были заполнены по-английски!

Видимая группа задает имя группы, которая будет отображатся в таблице, практически позволяет держать несколько таблиц в одной, переключая группы.

Таблица - это набор готовых адресов для игры. Работоспособность таблицы зависит от версии игры и операционной системы. В cлучаях не работоспособности адресов, Вам не нужно находить заново все изменившиеся адреса, а только один адрес. Потом используйте "Авто изменение адресов". Читайте главу Использование указателей и "Авто изменение адресов".


Редактор памяти

Редактор памяти/файлов

Как уже говорилось, ресурсы в игре (деньги, камни, лес, жизнь броня, и т.д.) обычно находятся рядом в памяти. Поэтому иногда имеет смысл обследовать некоторые участки памяти. Именно для этого нужен "Редактор памяти".
Если в настройках выбран объект - фаил(ы), тогда "Редактор памяти" превращается в "Редактор Файлов".
Редактор можно вызвать из контекстного меню основного окна программы. Редактор имеет настраеваемый интерфейс, на любой вкус.
Имеются четыре режима перемещения по редактору:
1. Перемещение по результатам поиска
2. Перемещение по таблице
3. Перемещение по блокам памяти (или файлам если выбрана папка)
4. Перемещение на адрес

Также настраивается вид каждой ячейки и текущей внизу окна. В случае отключения таймера обновления (время регенерации=0) следует использовать команду меню "Обновить". В режиме редактирования файлов таймер отключается автоматически.


Использование "Горячих клавиш"

В окне редактирования адреса можно назначить специальные клавиши для каждого адреса в таблице, что позволяют изменить значение по этому адресу из самой игры, не переключаясь на ArtMoney.

Эти клавиши буду работать только, если использование клавиш разрешено в настройках ( Смотри раздел "Описание настроек" ).

Кнопка "Замок" позволяет зафиксировать окно, для быстрого просмотра и редактирования установленных параметров при перемещении по таблице.


Вкладка - Основные

В качестве объекта можно выбрать процесс или фаил. Соответственно переключается режим работы.

Для просмотра процессов можно выбрать три режима: все, видимые и с окнами. Обычно игры попадают в видимые процессы.

Библиотеку для просмотра процессов следует менять, только если у вас проблемы с отображением процессов.

"Язык" - вы можете выбрать один из установленных языковых плагинов.

"Руководство пользователя" - вы можете выбрать одно из установленных руководств пользователя.

Режим "Экономить место на диске" запрещает сохранение промежуточных результатов на диске, что экономит место на диске, но не позволяет произвольно менять методы при отсеивании.

Режим "Разрешить отмену отсеиваний" позволяет отменять последнее отсеивание, если оно было ошибочное. Рекомендуется включить, если будете использовать поиск по формуле.

В платной редакции можно выбрать в качестве объекта - папку. Можно указать какие файлы должна просматривать программа по маске и времени модификации.


Вкладка - Дополнительные

Время регенерации - через этот интервал времени в миллисекундах происходит обновление значений в таблице. Только если объект - процесс.

Время заморозки - через этот интервал времени в миллисекундах происходит запись замороженных значений в память.

Показывать адресов - максимальное число адресов помещаемых в левую таблицу, рекомендуется 1000, более высокие значения могут привести к замедлению поиска.

Представление целых - позволяет просматривать целые числа со знаком минус, так и без него. По умолчанию целые числа считаются положительными, то есть беззнаковые.

Знаков после точки - используется при отображении чисел с точкой.

Обновлять значения в таблице только c фокусом у формы - позволяет вовремя игры не тратить время процессора на обновление значений таблицы. Рекомендуется устанавливать для слабых компьютеров.

Сохранять/Загружать значения в файлы-таблицы - при установке в файлы-таблицы записывается значения. Следует использовать только, если адреса всегда совпадают.

Шестнадцатиричный вид - При установке отображает все целые числа в шестнадцатиричном виде. Однако, при редактировании надо использовать букву "h" в конце. Работает в экспериментальном режиме.


Вкладка - Поиск

Вы можете сами поставить тип процесса, если вдруг программа определила его не правильно. Используйте тип WIN32 для процессов под Windows95/98/NT. Используйте тип WIN16 для процессов под Windows3.xx Используйте тип DOS для процессов под DOS

Почти всегда используется нормальный порядок байтов. Перевернутый порядок может пригодиться на старых играх или на эмуляторах типа "Моторола".

На время поиска вы можете полностью остановить выполнение процесса. Это увеличивает скорость сканирования до 50%.

Опция "Искать в диапазоне адресов" устанавливается, если вам примерно известен адрес переменной. Или устанавливается по команде "Искать в этом блоке памяти", при этом, помните, что галочка автоматически не снимается.

Приоритет сканирования определяет нагрузку процессора во время поиска и отсеивания. Рекомендую высокий приоритет, который примерно на 20% быстрее нормального. Полный приоритет увеличивает скорость сканирования на 30% и более, однако вы, возможно, не сможете отменить поиск, поскольку мышь будет блокирована.


Вкладка - Личные

Личные настройки используются для сохранения данных в таблице. Пожалуйста, заполняйте поля по-английски, чтобы ваше имя мог прочитать весь мир.

Не спрашивайте пароль снова - вы имеете возможность отключить проверку пароля при каждом запуске программы (только для платной версии).

Только для текущего пользователя Windows - вы имеете возможность разрешить работу с программой только одному пользователю Windows, который производил установку программы на компьютер (только для платной версии).


Вкладка - Интервейс

Настройки интерфейса позволяют изменять внешний вид программы. Установка шрифтов необходима для правильного отображения национальных языков.

"Скин" - вы можете выбрать установленные скины (обложки) для программы. Поддержка скинов (обложек), делает интерфейс приятным во всех отношениях. Использован продукт ThemeEngine ( автор Евгений Крюков www.ksdev.com ). Если вы хотите создать свой собсвенный скин загрузите специальную программу SkinEditor.

Регулировка яркости и цвета придает скину новый вид.

Использовать не официальные языковые плагины - Позволяет менять языковые плагины всем желающим.

Показать панель "Видимая Группа" - для тех кто работает с группами, установка этой галочки, добавляет на главную форму панель "Видимая Группа".

Показать главное меню - для тех кто любит большие меню.


Вкладка - Клавиши

Некоторые игры не позволяют вам переключаться на другие приложения, поэтому сочетания клавиш Alt+Tab, Ctrl+Esc не работают, тогда вы можете попытаться принудительно переключиться на ArtMoney, используя клавишу всплытия.

Клавиша "Выбрать текущий процесс" может пригодиться, если вы не видете процесс в списке процессов. Клавиши по умолчанию присваиваются каждому адресу в таблице при добавлении.

Клавиши по умолчанию присваиваются каждому адресу в таблице при добавлении.


Описание версий программы
Что нового в версии 7.10 ( 17 октября 2004 года )
· Исправлена ошибка с неправильным определением области поиска.

Что нового в версии 7.09 ( 3 октября 2004 года )
· [PRO] Новая функция. Сохранение и загрузка процесса. Может использоваться для сохранения игр, где это не предусмотрено. Требования: Windows 2000/XP/2003. Ограничения: Нельзя перезапускать процесс. Для больших игр действует только внутри одного уровня. Пока работает не на всех играх, может повесить игру. Будем работать над улучшением. Подробнее читайте в руководстве пользователя.
· Добавлено окно для просмотра карты процесса. С возможностью сохранения в Excel.
· Исправлена ошибка с неправильным отображением форм при размере шрифта не равным стандартному 96 dpi. Например, часто для нотбуков используют 120 dpi.
· Исправлена ошибка с неправильным действием горячих клавиш при использовании групп.
· Исправлена ошибка в редакторе при перемещение по результатам поиска.
· Исправлены другие мелкие интерфейсные ошибки.
· [SE] В английскую версию SE добавлено рекламное програмное обеспечение "AT-Partners", которое рекламирует сайт at-games.com, добавляя его в избранное. Удаляется через панель управления "Удаление/установка программ" под именем ATP.

Что нового в версии 7.08 FE ( 26 июля 2004 года )
· Выпущена специальная английская редакция программы FE, для выпуска на CD в северной америке. Исправлены английское руководство и плагин, в соответсвии с требованиями издателя. В ней открыты три PRO функции:
1) В качестве объекта можно использовать каталог или диск.
2) Дополнительные условия при поиске и отсеивании.
3) Поиск строк.

Что нового в версии 7.08 ( 10 мая 2004 года )
· Несколько процедур были оптимизированы и ускорены.
· Все руководства пользователя сконвертированы в формат CHM. В английском руководстве произведена грамматическая проверка.
· Новые иконки.
· Исправлены несколько ошибок с прорисовкой интерфейсных элементов. Теперь меню открывается без щелчка мыши

Что нового в версии 7.07 ( 21 февраля 2004 года )
· Теперь ArtMoney умеет открывать системные процессы в Windows NT4/2000/XP/2003.
· Лучшая поддержка для Windows Server 2003
· Исправлена ошибка с иногда появляющемся сообщением "I/O error 102 или 103"
· Исправлена ошибка с неправильной работой при включенном экономичном режиме.
· Исправлены ошибки при работе со скинами

Что нового в версии 7.06 ( 15 декабря 2003 года )
· Теперь ArtMoney позволяет использовать в качестве скинов (обложек), так называемые визуальные стили ( англ. Visual Styles), разработанные для операционной системы Windows XP. Работает в любом Windows. В настоящее время существуют тысячи бесплатных визуальных стилей, которые вы легко можете использовать без какой-либо модификации. Например, на сайте themexp.org вы можете скачать более тысячи различных стилей (файлы с расширением msstyles).
· Руководство пользователя теперь устанавливается и выбирается в настройках также, как и языковые плагины.
· Добавлено автоматическое определение перезапуска или закрытия процесса.
· Добавлена настройка "Обновлять значения в таблице только c фокусом у формы".
· Исправлена ошибка с обновлением таблицы в файловом режиме.
· Исправлены несколько незначительных ошибок с прорисовкой интерфейсных элементов.
· [SE] Исправлена ошибка при повторном поиске не участвовали новые адреса.
· [SE] Исправлена ошибка при поиске в диапазоне адресов.

Что нового в версии 7.05 ( 9 ноября 2003 года )
· Переделана процедура всплытия по нажатию клавиши.
· Добавлены новые клавиши "Остановить процесс и всплыть" и "Переключиться и продолжить процесс".
· Исправлена ошибка с переключением групп.

Что нового в версии 7.04 ( 19 октября 2003 года )
· Исправлена ошибка при работе с кодировками.

Что нового в версии 7.03 ( 12 октября 2003 года )
· Исправлена ошибка при отсеивание неизвестного значения.
· Добалены кнопки "По умолчанию"
· [PRO] Улучшен анализ формулы. Теперь формула может содержать набор аргументов в квадратных скобках.

Что нового в версии 7.02 ( 6 октября 2003 года )
· Исправлена ошибка при загрузке таблиц.
· Исправлена ошибка при первом отсеивание неизвестного значения не рисовалась шкала.
· Исправлена ошибка рисования курсора при редактировании комментария.
· Обновление скин-пакета ThemeEngine до версии 3.66. Новые скины!

Что нового в версии 7.01 ( 30 сентября 2003 года )
· Исправлена ошибка при поиске указателей.
· Исправлена ошибка при рисовании форм.
· Добавлена клавиша "Записать дамп памяти".

Что нового в версии 7.00 ( 21 сентября 2003 года )
· Теперь ArtMoney v7 выпускается в двух редакциях. Первая редакция v7 SE (Special Edition)- бесплатная. Вторая редакция v7 PRO (профессиональная) - стоит денег, для жителей России и стран СНГ - $10, для остальных стран $20 на одного пользователя. Вы платите только один раз, все последующие обновления бесплатны. Платная версия содержит ряд дополнительных функций и механизмов, таких как отсеивание по формуле, дающих практически 100% результат! Далее в описании версий будет использоваться значок [PRO], который показывает, что данный пукнт относится только для редакции PRO.
· Полностью переделан механизм поиска и отсеивания. Работа с файлами, как с процессами. В них можно искать и отсеивать. Пригодится, чтобы найти искомое значение в файлах игры. В настройках указывается объект (фаил или процесс).
· Поддержка скинов (обложек), делает интерфейс приятным во всех отношениях. Регулировка яркости и цвета. Управление шрифтами. Использован продукт ThemeEngine 3.62 ( автор Евгений Крюков www.ksdev.com ). Если вы хотите создать свой собсвенный скин загрузите специальную программу SkinEditor.
· Новый тип данных - Целое 3 байта, специально для эмуляторов типа ePSXe, ZSNES и ROCKNES.
· Новые типы данных - Нуль конечная строка и Паскаль строка.
· Поддержка кодировок для текста и строк, в том числе UNICODE. Формат таблицы кодировок полностью совместим с программой FarManager (www.rarsoft.com).
· Добавлены команда "Остановить процесс", полностью прекращает выполнение выбранного процесса. И конечно добавлена команда "Продолжить процесс", которая продолжает выполнение процесса. Добавлена настройка "Останавливать процесс вовремя поиска".
· Добавлена настройка "Сохранять/Загружать значения в файлы-таблицы".
· Добавлена настройка "Библиотека для просмотра процессов", по умолчанию АВТО.
· Добавлено главное меню программы (отключаемое в настройках).
· Добавлена настройка "Использовать не официальные языковые плагины", которая позволяет менять языковые плагины всем желающим.
· [PRO] В качестве объекта можно использовать каталог или диск. Если вам неизвестно в каком именно файле это хранится. Добавлены настройки сканирования папок (маска фалов и время модификации).
· [PRO] Дополнительные условия ('<','>','<=' и т.д.) при поиске и отсеивании.
· [PRO] Отсеивание по формуле. Сохраните несколько раз дамп памяти. Вы имеете несколько состояний объекта M1,M2, и т.д. Например состояние полоски жизни одинаково на 1 и 3 состоянии. Теперь сделайте отсеивание по формуле "(M1<>M2)and(M2<>M3)and(M1=M3)". И вы легко нашли адрес жизни.
· [PRO] Дополнительное ограничение. Поиск строк возможен только в редакции PRO.

Что нового в версии 6.27 ( 20 июля 2003 года )
· Исправлена ошибка (при отсеивание пропускались некоторые адреса).

Что нового в версии 6.26 ( 26 февраля 2003 года )
· Исправлены ошибки интерфейса (особенно при переключение групп).

Что нового в версии 6.25 ( 8 февраля 2003 года )
· Скорость сканирования значительно увеличена.

Что нового в версии 6.24 ( 31 января 2003 года )
· Ошибки исправлены.

Что нового в версии 6.23 ( 20 января 2003 года )
· Для тех кто работает с группами, теперь можно добавить на главную форму панель "Видимая Группа" (установите галочку в настройках).
· Добавлена команда "Преобразовать указатели в адреса". Обратная команда к "Установить указатель". Только на выбранные строки.
· Добавлена команда "Установить фильтр". Позволяет оставить в таблице только указанные значения. Можно использовать для отсеивания указателей.
· "Набор символов" теперь указывается для каждого шрифта.
· При выборе нового процесса результаты поиска больше не обнуляются.
· В редактор памяти добавлена команда "Сохранить адрес/указатель",
· Команда "Изменить выбранные" теперь умеет прибавлять смещение к адресам.
· Исправлена ошибка с полосой прокрутки в редакторе памяти.
· Исправлена ошибка с переключением языковых плагинов.
· Другие ошибки исправлены.

Что нового в версии 6.22 ( 7 января 2003 года )
· Новый параметр в настройке - "Набор символов". Позволяет корректно отображать языковые плагины, в случае если в Windows проставлен не правильный язык по умолчанию. Например, у вас стоит язык - английский, в этом случае не всегда русский отображается корректно, в этом случае нужно выбрать набор символов "Cyrillic".
· Новая клавиша в настройке - "Выбрать текущий процесс", по умолчанию Ctrl-F11. Может пригодиться, если вы не видете процесс в списке процессов.
· В редактор памяти добавлено поле "текущей адрес", улучшено перемещение.
· Исправлены ошибки.

Что нового в версии 6.21 ( 27 декабря 2002 года )
· Скорость сортировки значений в таблице в несколько раз увеличена.
· В языковой плагин добавлен "формат даты". Изменена процедура проверки плагинов.
· Исправлены ошибки.

Что нового в версии 6.20 ( 19 декабря 2002 года )
· Исправлена ошибка при замораживании значений с указателями.

Что нового в версии 6.19 ( 14 декабря 2002 года )
· Работа с указателями. Поиск и установка указателей. Для тех кто не знает, привязка значения к указателю позволяет бороться со случайным рапределением памяти. В помощи подробно описано как это делать.
· Группировка найденных значений. Команды выбора группы и установки видимой группы.
· Новая команда "Изменить выбранные ячейки". Позволяет у выбранных значений менять любой параметр.
· Сортировка в таблице по описанию,адресу,значению,группе.
· В редактор памяти добавлена команда "Обновить", нужна в случае отключения таймера обновления.
· Объединение двух таблиц (только одного автора!). Для объединения щелкните правой клавишей мыши на кнопке "Загрузить".
· Исправлена ошибка с сохранением таблиц (Имя файла иногда не сохранялось).
· Новый параметр в настройке - "Шестнадцатиричный вид".
· Помощь значительно переработана.

Что нового в версии 6.18 ( 13 ноября 2002 года )
· В таблице теперь можно выбирать строки по продвинутой схеме с нажатием Shift и Ctrl. Добавлена команда "Выбрать наоборот", которая инвертирует выбранные строки.
· В редактор памяти добавлена "полоса прокрутки" и команда выравнивания ячеек.
· Исправлена ошибка с неправильным поиском значения типа "с точкой 4 байта" (в версиях 6.15-6.17)

Что нового в версии 6.17 ( 21 сентября 2002 года )
· Полная поддержка типа "Целое 8 байт". Этот тип используется для значений больше 4 миллиардов.
· Исправлены ошибки с обновлением ячеек и с редактированием текста в таблице

Что нового в версии 6.16 ( 17 сентября 2002 года )
· Исправлена ошибка с удалением ячеек в таблице

Что нового в версии 6.15 ( 9 сентября 2002 года )
· Продвинутый редактор памяти.

Что нового в версии 6.14 ( 14 июля 2002 года )
· Исправлены ошибки интерфейса.

Что нового в версии 6.13 ( 9 июля 2002 года )
· Изменения в интерфейсе. Добавлены настройки интерфейса (шрифты,цвета и форма кнопок)
· Добавлено отсеивание значений по условию 'увеличилось на' и 'уменьшилось на' при поиске неизвестного значения
· На втором шаге разрешено использовать условие "не изменилось" при поиске неизвестного или кодированного значения
· Исправлены ошибки и глюки.

Что нового в версии 6.12 ( 25 февраля 2002 года )
· По нажатию горячей клавиши должен лучше всплывать.
· Небольшие изменения в интерфейсе.
· Исправлены все известные на сегодня ошибки. Надеюсь больше их не осталось :-)

Что нового в версии 6.11 ( 20 января 2002 года )
· Добавлен параметр "Представление целых", который позволяет просмотривать целые числа со знаком минус, так и без него. По умолчанию целые числа считаются положительными, то есть беззнаковые.
· Можно делать поиск диапазона чисел, только по одному параметру. То есть можно отобрать числа больше первой границы, или отобрать числа меньше второй границы.
· Можно отменять последнее отсеивание, если оно было ошибочное и если в настройке это разрешено. В случае ошибочной отмены, отсеивание можно вернуть.
· Можно сохранить результаты отсеивания/поиска и позже загрузить их. Например можно начать ломать игру, сохранить отсеивание, и продолжить через неделю.
· Исправлены некоторые ошибки.

Что нового в версии 6.10 ( 22 августа 2001 года )
· Механизм обработки горячей клавиши был полностью переделан. Повышена стабильность работы. По умолчанию устанавливается горячая клавиша Ctrl-F12.
· Теперь можно назначить специальные клавиши для каждого адреса в таблице, что позволяют изменить значение по этому адресу из самой игры, не переключаясь на ArtMoney.
· Сохраняемые таблицы с этой версии имеют расширение AMT. Сделана процедура автоматической деинсталяции программы.
· Скорость отсеивания значительно увеличена.
· Открыт сайт ArtMoney www.artmoney.ru
· Исправлена куча багов.

Что нового в версии 6.09 ( 26 мая 2001 года )
· Добавлен тест на быстродействие процессора и памяти.
· Добавлено автоматическое определение типа игры.
· Для просмотра процессов теперь можно выбрать три режима: все, видимые и с окнами.
· Добавлено контекстное меню при выборе процессов с командами "Информация о процесс" и "Убить процесс". "Информация о процесс" содержит полное имя файла, тип процесса и размер данных.
· Изменена структура сохраняемых таблиц. Добавлены имя EXE файла игры и многострочный комментарий. Присылайте сделанные вами таблицы, и они обязательно будут опубликованы на сайте ArtMoney.
· Исправлены разные глюки. В том числе в Windows NT/2000 не правильно обрабатывались некоторые DOS игры. Оптимизация под Windows 2000.

Что нового в версии 6.08 ( 30 декабря 2000 года )
· Теперь языки выполнины в виде плагинов, они могут создаваться и распрастраняться отдельно от программы. Сейчас доступны языковые плагины: русский, английский, немецкий, итальянский, латышский. Надеюсь скоро будет еще. Если вы хотите создать новый языковой плагин, то напишите мне и вы получить пароль на редактирование плагинов. Все что вам для этого надо сделать это открыть фаил, например, русского плагина любым текстовым редактором и перевести его.
· Исправлен блок программы поиска чисел с точками. Ранее на процессорах фирмы AMD (K6,K6-2,Athlon,Duron) возможны были сбои системы с синим экраном при поиске чисел с точкой.
· В таблице добавилась команда контекстного меню "установить значение" на выбранные адреса с возможностью установить шаг для значения.
· Левую таблицу теперь тоже можно изменять по ширине колонок и общую ширину ( Ctrl-Left, Ctrl-Right ).
· Прогноз оставшегося времени теперь более точный. И другие мелкие ошибки исправлены.

Что нового в версии 6.07 ( 14 августа 2000 года )
· Добавлен поиск в диапазоне адресов. Добавлена команда "Искать в этом блоке памяти", что позволяет найти один ресурс, а остальные уже искать в том же блоке памяти, что значительно быстрее.
· Добавлена опция "Экономить место на диске". По умолчанию "не экономить", что теперь позволяет произвольно менять методы при отсеивании. То есть, например, вы ищете неизвестное значение, потом диапазон и снова неизвестное значение.
· Оптимизация и исправления ошибок. Лучше всплывает по нажатию горячей клавиши. Сканирование стало немножко быстрее.
· Теперь можно выбрать немецкий язык и есть полная помощь на немецком. Если вы хотите перевести на другой язык, то пишите мне.

Что нового в версии 6.06 ( 20 мая 2000 года )
· Добавлен поиск неизвестного значения ( то есть по условию увеличилось/уменьшилось )
· Исправлены различные ошибки ( в том числе при поиске диапазона для чисел с точкой )
· Добавлены клавиши для сортировки в таблице ( Ctrl-Up, Ctrl-Down ) и для записи таблицы ( Ctrl-S )

Что нового в версии 6.05 ( 20 марта 2000 года )
· Добавлен поиск диапазона значений.
· Теперь вы можете менять тип и метод при отсеивании.

Что нового в версии 6.04 ( 27 февраля 2000 года )
· Изменена структура сохраняемых таблиц. Теперь в ней сохраняются также сведения о том, кто и где её сделал. Присылайте сделанные вами таблицы, и они будут помещены на сайте программы.
· Добавлены дополнительные и личные настройки. В том числе добавлена регулировка приоритета, которая позволяет увеличить скорость сканирования на 30% и более.

Что нового в версии 6.03 ( 1 февраля 2000 года )
· Теперь по нажатию горячей клавиши лучше всплывает.
· Исправлена ошибка неправильной заморозки после использования "Авто изменение адресов".
· Помощь дополнена и к ней добавлены "Часто задаваемые вопросы и ответы".

Что нового в версии 6.02 ( 5 ноября 1999 года )
· Исправлены ошибки:
· - неправильный заголовок таблицы
· - неправильный ввод значений в таблице после загрузки таблицы
· - неправильный ввод значений в таблице после поиска последовательности чисел

Что нового в версии 6.01 ( 23 октября 1999 года )
· Исправлены ошибки:
· - заморозка значений иногда не выполнялась
· - неправильный ввод текстовых значений в таблице
· - неправильное добавление в таблицу последовательности значений

Что нового в версии 6.00 ( 25 сентября 1999 года )
· Новый интерфейс для Windows 9x/NT. 90% переделка всего кода.
· Возможность выбрать процесс. Работа с логическими адресами.
· Возможность искать значения всех типов одновременно. Автоопределение типа из выбранных.
· Поиск кодированного значения.
· Команда "Авто изменение адресов".
· Вызов по горячей клавише для игр, которые запрещают ALT-TAB.
· Бесконечное количество найденных и замороженных значений


Часто задаваемые вопросы и ответы

· 1. Можно ли при помощи вашей программы попытаться изменить время в игре или вообще его отсчет заморозить?
· 2. В программе все элементы управления не умещаются на формах, надписи на кнопках выползают за границы. Что делать?
· 3. После загрузки сохраненных данных их значения обнуляются, приходится каждый раз устанавливать значения ручками. Как с этим бороться?
· 4. После загрузки сохраненной таблицы ее значения равны <НЕТ> или не совпадают с текущими в игре. Что делать?
· 5. Что делать, если в игре полоска без цифр? Как найти это значение?
· 6. Я нашел адрес, меняю значение в ArtMoney, переключаюсь в игру, но в игре ничего не изменилось Что делать?
· 7. Можно ли с помощью ArtMoney изменять деньги в сетевых или онлайн играх?
· 8. Как правильно выбрать тип для поиска?
· 9. ArtMoney при поиске вылетает. Что делать?
· 10. ArtMoney ничего не находит. Что делать?
· 11. Когда ищу значение в игре, artmoney зависает и поиск останавливается. Что делать?
· 12. А есть ли в вашей программе поддержка шестнадцатиричных чисел ?
· 13. Как сломать игры Command & Conquer, Tiberian Sun, Dune 2000, Red Alert ?
· 14. Как сломать игру Quake I ?
· 15. Как сломать игру Diablo I ?
· 16. Как сломать игру Age Of Empires 1,2 ?
· 17. Как сломать игру Аллоды 1,2,3 (они же - проклятые земли) ?
· 18. Как сломать игру Warcraft 3 ?
· 19. Как сломать игру "Космические рейнджеры"?
· 20. Помогите! У меня не получается взломать игру?
· 21. Как менять языковые плагины?
· 22. Игра не появляется в списке процессов, что делать?
· 23. Что такое таблицы и как их использовать?

1. Можно ли при помощи вашей программы попытаться изменить время в игре или вообще его отсчет заморозить?
Два варианта:
а) Если в игре есть кнопка пауза. Обычно клавиша "P" или клавиша "Pause", иногда пробел. То нажимает её. Переключаетесь в мою программу. Ищем секунды ( или минуты ). Переключаетесь в игру. Пускаете время в ней. Опять жмёте "пауза". Переключаетесь в ArtMoney. Отсеиваем, сколько секунд ( или минут ) стало. Далее повторяем действия, пока не останется один истинный адрес. Обычно трёх раз достаточно. Далее добавляем адрес в таблицу и замораживаем его.
б) Если в игре нет "Паузы", тогда всё усложняется. Переключаетесь в мою программу. Ищем минуты ( только минуты ! ). Переключаетесь в игру. Ждёте, пока минута изменится. Переключаетесь в ArtMoney. Вводим, сколько минут стало. Далее повторяем действия, пока не останется один истинный адрес. Обычно трех раз достаточно. Далее добавляем адрес в таблицу и замораживаем его.

Дополнительные советы:
1) Переводите время в секунды и ищете их, только рекомендуется искать диапазоном, то есть у вас 3:14 это 194 секунд. Ищете диапазон с 192 до 196 целые.
2) Просто секунды тоже ищете в диапазоне, то есть с 12 до 16 целые.

Назад

2. В программе все элементы управления не умещаются на формах, надписи на кнопках выползают за границы. Что делать?
На это влияет размер шрифта (устанавливается в свойствах экрана там же где и разрешение). Нормальный размер - 96 dpi, если это не помогает, то следует установить русский офис 97 или выше.

Назад

3. После загрузки сохраненных данных их значения обнуляются, приходится каждый раз устанавливать значения ручками. Как с этим бороться?
Вообще то, так задумано с самого начала, - сохраняются только адреса, а не значения, поскольку эти адреса могут использоваться на других процессах, или адреса могут не совпадать из-за динамического распределения памяти. Значения не обнуляются, а заменяются текущими.

Назад

4. После загрузки сохраненной таблицы ее значения равны <НЕТ> или не совпадают с текущими в игре. Что делать?
Это означает, что по этим адресам нет данных, то есть адреса не совпали из-за динамического распределения памяти. В этих случаях вам не нужно находить заново все изменившиеся адреса, а только один адрес. Потом используйте "Авто изменение адресов".

Назад

5. Что делать, если в игре полоска без цифр? Как найти это значение?
В этом случае вы должны использовать поиск "Неизвестное значение".

Назад

6. Я нашел адрес, меняю значение в ArtMoney, переключаюсь в игру, но в игре ничего не изменилось Что делать?
Вы нашли не верный адрес. Пробуйте другие методы и настройки. Если ничего не помогает, вы должны использовать поиск "Кодированное значение" или поиск по формуле для кодированного значения.

Назад

7. Можно ли с помощью ArtMoney изменять деньги в сетевых или онлайн играх?
Программа ArtMoney не предназначена для взлома сетевых или онлайн игр. Трудность в том, что деньги могут дублироваться на нескольких компьютерах, и изменение денег на одном (на вашем ) может не привести к успеху. Тут всё зависит от игры. Лучше всего для сетевой игры запускать ArtMoney на сервере, что, скорее всего, невозможно.

Назад

8. Как правильно выбрать тип для поиска?
Для денег обычно надо брать 4 байта, для жизни 1-2 байта, в остальных случаях 2 байта. В большинстве игр используется целый тип, но есть и исключения.

Тип | Диапазон | Примечание
Целое 1 байт | от 0 до 255 | Обычно жизнь,количество предметов если их мало
Целое 2 байта | от 0 до 65535 | Обычно жизнь,количество предметов, ресурсы
Целое 4 байта | от 0 до 4294967295 | Обычно деньги
Целое 8 байт | от 0 до 18446744073709551616 | Деньги если они измеряются миллиардами

Назад

9. ArtMoney при поиске вылетает. Что делать?
Возможно, вы пользуетесь какими то программами для защиты памяти от вирусов.

Назад

10. ArtMoney ничего не находит. Что делать?
Попробуйте сменить тип игры на ВСЕ и убедитесь, что у вас в настройках не стоит галочка "Искать в диапазоне адресов". Попробуйте другие методы.

Назад

11. Когда ищу значение в игре, artmoney зависает и поиск останавливается. Что делать?
Если система повисла во время поиска, обычно это значит, что закончилось место на диске.
Освободите место на диске или купите больше памяти и больший жесткий диск. Возможно также, что у вас перегрев процессора, заменить вентилятор!

Назад

12. А есть ли в вашей программе поддержка шестнадцатиричных чисел ?
Да, просто добавте при вводе числа в конце букву h.

Назад

13. Как сломать игры Command & Conquer, Tiberian Sun, Dune 2000, Red Alert ?
Вся серия игр C&C хорошо ломается, когда у вас нет тибериум-завода, т.е. строения, куда приезжает комбайн. Его необходимо продать, тем более что после слома денег, он не нужен.

Назад

14. Как сломать игру Quake I ?
Тип игры - DOS, тип переменной - с точкой 4 байта.

Назад

15. Как сломать игру Diablo I ?
Деньги в Diablo разбиваются на кучки по пять тысяч, нужно найти адрес в памяти одной кучки и заморозить там пять тысяч. Потом берите из этой кучи 4999, а там всё равно будет 5000.

Назад

16. Как сломать игру Age Of Empires 1,2 ?
Тип переменной - с точкой 4 байта. Попробуйте искать в диапазоне с погрешностью до одного. Например, золота 2456, тогда ищите диапазон от 2455 до 2457.

Назад

17. Как сломать игру Аллоды 1,2,3 (они же - проклятые земли) ?
Сломать деньги очень сложно. Намного проще сломать количество предметов. Например, поставте себе один миллион мечей и продайте их, получите кучу денег.

Назад

18. Как сломать игру Warcraft 3 ?
В игре Warcraft 3 значение денег зашифровано, причем очень просто, количество денег умножено на 100. То есть, если у вас 1250, то искать надо 125000. Плюс легко ломается, без какого либо шифрования, количество золота в шахте - а ведь это бесконечные деньги. Также легко ломаются параметры героя (опыт,сила и т.д.).

Назад

19. Как сломать игру "Космические рейнджеры"?
К сожалению разработчики не все и не везде закодировали. На экране квестов ломаются все цифры стандартным способом. Итак, пиратствуем, садимся на враждебную планету, тебя сажают в тюрьму , там есть библиотека и слепой. Кидай ему денежку и применяй ArtMoney. А так же дату выхода ставим 0 и выходим на следующий день с большими деньгами. Надеюсь, что в следующем патче разработчики "дырку" закроют, Так что используйте читы, ищите их на сайте http://www.ElementalGames.com/rus/.

Назад

20. Помогите! У меня не получается взломать игру?
Вы уверены что использовали все методы, типы и другие настройки в ArtMoney? Программа имеет много настроек, и нужно только определить, какие для какой игры установить. Я еще не видел игры, которая не ломалась бы методом поиска кодированного значения. В любом случае, вы можете поискать игру в разделе таблиц на сайте программы и написать автору этой таблицы.

Назад

21. Как менять языковые плагины?
Поставте в настройках галочку "Использовать не официальные языковые плагины". Редактируйте плагин в любом текстовом редакторе. Чтобы сделать плагин официальным напишите нам письмо для получения инструкций. Укажите в письме какой язык и откуда вы его знаете. Спасибо.

Назад

22. Игра не появляется в списке процессов, что делать?
1) Установите в настройках "Показывать процессы" на "ВСЕ".
2) Попробуйте установить в настройках "Библиотека для просмотра процессов" разные значения, поочереди.
3) Попробуйте клавишу "Выбрать текущий процесс".
4) Если ваша игра работает в Internet Explorer. Выберите "Program Manager". Это одно и тоже.

Назад

23. Что такое таблицы и как их использовать?
Таблица - это набор готовых адресов для игры.
Работоспособность таблицы зависит от версии игры и операционной системы.
В cлучаях не работоспособности адресов, Вам не нужно находить заново все изменившиеся адреса, а только один адрес. Потом используйте "Авто изменение адресов". Читайте главу Использование указателей и "Авто изменение адресов".

Назад


Полезные советы

В хелпе очень много полезной информации, но её иногда явно не достаточно. Хотел поделиться некоторыми "хитринками".

Авось кому помогут. Тем более, что разработчики игр нынче не глупые пошли и пытаются

1. Кодировать свои значения
2. Ограничить вход/выход из игры горячими клавишами
3. Делать сразу и то и другое

Как бороться с первой проблемой вскользь упоминается в хелпе.
Но на этом стоит акцентировать внимание. Самые популярные для взлома значения - деньги и навыки.

Рассмотрим основные проблемы, с которыми можно столкнуться.

1. Деньги невозможно найти никакими способами (как было в КР или империум галактике) Самое простое в таком случае это не сидеть и искать часами значение, а пораскинуть мозгами и найти смежные значения (те, которые влияют на цену). Так, к примеру в КР было сложно найти деньги, но я нашёл износ детали, взломал износ, поставил на несколько миллиардов и цена на деталь резко (в тысячи раз =) ) возросла... В галактике же это были люди на планете. На день я ставил на планете до %%% людей и получал до %%% бабла =) С навыками примерно так же...

2. Теперь об ограничении входа/выхода. Если ограничение входа в игру после альт-таба, то надо делать так - запустить игру, свернуть, искать значение, убить её, запустить снова, изменить значение, свернуть, выбрать её как процесс, отсеять, убить и т.д. Если на выход , то альт+контрл+дел обычно справляется.

В 3-ем пункте уже надо применять логику и действовать по обстоятельствам.

Спасибо за внимание, Defil (defil@pisem.net).